Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
pmaports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
postmarketOS
pmaports
Commits
aab39fc9
Verified
Commit
aab39fc9
authored
9 months ago
by
Jane Rachinger
Committed by
Clayton Craft
6 months ago
Browse files
Options
Downloads
Patches
Plain Diff
systemd/alpine-base: remove stub `rc-update` (MR 5377)
parent
add55672
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
extra-repos/systemd/alpine-base/APKBUILD
+2
-6
2 additions, 6 deletions
extra-repos/systemd/alpine-base/APKBUILD
extra-repos/systemd/alpine-base/rc-update
+0
-41
0 additions, 41 deletions
extra-repos/systemd/alpine-base/rc-update
with
2 additions
and
47 deletions
extra-repos/systemd/alpine-base/APKBUILD
+
2
−
6
View file @
aab39fc9
...
...
@@ -2,7 +2,7 @@
pkgname
=
alpine-base
pkgver
=
9999
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Meta package for minimal alpine base"
url
=
"https://alpinelinux.org"
arch
=
"noarch"
...
...
@@ -20,10 +20,9 @@ depends="
subpackages
=
"alpine-release:release"
replaces
=
"alpine-baselayout"
options
=
"pmb:strict !check"
source
=
"rc-update"
package
()
{
install
-Dm755
rc-update
"
$pkgdir
"
/usr/bin/rc-update
mkdir
-p
"
$pkgdir
"
}
release
()
{
...
...
@@ -32,6 +31,3 @@ release() {
mkdir
-p
"
$subpkgdir
"
}
sha512sums
=
"
18227112a559e2b90c9a3cf4eb16762595370130c88cb7b7d1a0fda2ba894918802dd084f7c505f8eb379f078d4c2ed2e384f03d16ff25075acdb31ab0186813 rc-update
"
This diff is collapsed.
Click to expand it.
extra-repos/systemd/alpine-base/rc-update
deleted
100644 → 0
+
0
−
41
View file @
add55672
#!/bin/sh
# Dummy to make post-install scripts work
# Will fail in chroot for sysV compat services
# FIXME: FIXME: FIXME: FIXME: FIXME:
# Get the last argument to rc-update, it's
instruction
=
"enable"
for
service
;
do
case
"
$service
"
in
"rc-update"
)
;;
"-q"
)
;;
"add"
)
instruction
=
"enable"
;;
"del"
)
instruction
=
"disable"
;;
*
)
break
;;
esac
done
case
"
$service
"
in
"networkmanager"
)
service
=
"NetworkManager"
;;
"modemmanager"
)
service
=
"ModemManager"
;;
esac
# The service files might be missing due to how apk orders the install
# so we record them all to let systemd-services.trigger enable them
# at the end of installation
if
!
systemctl
$instruction
$service
;
then
echo
"
$instruction
$service
"
>>
/run/rc-update.failed
fi
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment